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1. INSTALAR ODV 
 
El programa Ocean Data View (ODV) es gratuito para fines no comerciales, sólo 
requiere de un registro previo para poderlo descargar desde la web . Resulta 
conveniente visitar la web del programa, pues además de encontrar el software 
para su instalación tenemos también numerosas bases de datos a las que se 
puede acceder de forma inmediata con ODV. Por otro lado, la web dispone de 
un foro muy activo para atender las dudas que puedan plantarse en relación con 
el manejo del programa, además de ser un expacio en el que enviar las 
sugerencias de mejora que pudiéramos tener sobre el programa. 	
La última versión del programa puede instalarse en Windows (XP, Vi), Mac OS 
X, Linux y UNIX. Una vez descargado el archivo, el proceso de instalación no 
presenta ningún detalle a destacar más allá de los ajustes habituales.	
 
 

2. IMPORTAR DATOS EN ODV 
 

El proceso de importación de datos con ODV es uno de los aspectos en los que 
ODV ha mejorado en los últimos años, pues en las versiones anteriores el 
proceso no era nada intuitivo y suponía una auténtica barrera de entrada para 
quienes intentaban trabajar con el programa. 

El mundo de la oceanografía observacional está caracterizado por una 
innumerable cantidad de formatos en que pueden presentarse los datos, y en 
este sentido los desarrolladores de ODV han hecho un notable esfuerzo para 
incorporar procesos de importación que cubran el amplio abanico de formatos 
con los que nos podemos encontrar. 

 

El menú de importación de ODV 
nos indica los diferentes tipos de 
formatos que tiene predefinidos. 
La idea esencial es que podemos 
entrar en cada uno de los 
apartados y seleccionar el tipo de 
archivo correspondiente y ya 
tendríamos los datos cargados en 
nuestro espacio de trabajo. 
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En tanto que el proceso es inmediato en la mayoría de las opciones, nosotros 
nos centraremos en este apartado únicamente en la primera opción, la que lleva 
por título ‘ODV Spreadsheet’. Esta opción es la que nos va a permitir importar en 
ODV los datos que hayamos producido nosotros. 

El único requisito que impone ODV a la hora de importar nuestros datos es que 
en cada observación tengamos información sobre la localización espacial de esa 
observación. A partir de ahí, el proceso es muy flexible. Con seguridad  la forma 
más directa e intuitiva para importar nuestros datos en ODV es arrastrando el 
archivo de datos hasta el icono de ODV o hasta una pantalla de ODV en blanco 
y así el propio programa realizará esta tarea. 

 

Para poder importar un archivo Excel, éste debe cumplir una serie de 
condiciones mínimas, además de la indicada anteriormente: 

‐ Tener un cabecero, que la primera fila estén representados el nombre de 
las variables 

‐ Que las columnas estén lo suficientemente separadas para que de forma 
visual no se unan los números de cada columna. En caso de no estarlo 
ampliar el ancho de las columnas para lograrlo. 

‐ Debe estar especificada la Latitud - Longitud y estación, cada uno de ellos 
en una columna diferente. Para ODV esta información es imprescindible, 
porque es un programa georreferenciado. 

‐ Debe guardarse el archivo en formato CSV separado por comas. 

Una vez hecho todo esto, es conveniente revisar si los datos han sido guardados 
correctamente abriendo el archivo con “Bloc de notas” o un lector de archivos 
.txt. 

La fecha debe estar en formato de 3 columnas diferentes como “Day”, “Month”, 
“Year”. Si esta información está en una sola columna será conveniente 
reconvertirla a tres columnas para que pueda ser útil esta información en ODV y 
el programa pueda hacer uso de ella si nuestros datos fuesen, por ejemplo, una 
serie temporal. 

Al importar datos, hay que especificar qué tipo de separación de datos tenemos 
(revisar para esto siempre el archivo CSV creado en un visor de texto plano tipo 
Bloc de notas). En nuestro caso están separadas por punto y coma, ya que el 
Excel en versión latina toma las comas como separador de decimales. 

Cuando vamos a importar datos que tengan un formato específico o propio, hay 
que tener muy en cuenta la lectura del cabecero al leerlo en el bloc de notas, ver 
cuántas filas son el cabecero en total, en qué fila se indican las unidades y en 
qué filas comienzan los datos de las variables. A veces puede que no reconozca 
las unidades si no está en todas las columnas; en ese caso pondríamos la misma 
fila que el dato del nombre de las variables.  
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Si el archivo no viene con el dato de latitud y longitud y es la misma para todo el 
archivo, le podemos definir un dato por defecto (“set default” en “Meta variable 
Association” cuando hagamos la definición de metadatos y la asociación entre 
variables). Este paso es necesario para que te deje avanzar, ya que para ODV 
la latitud y longitud son imprescindibles. 

 

 

Además, habrá que definir el dato “Column labels lines”, que especifica el 
número de líneas que ocupa la cabecera, la fila de unidades en caso de tenerla 
y la línea donde comienzan los datos propiamente dichos. 

Si todos los datos son correctos deben aparecer las columnas que teníamos en 
el Excel como variables a la derecha (“Column labels”) una variable por fila, tal y 
como se muestran en la figura anterior. Si no aparecieran estas variables es que 
el ODV no están entendiendo el archivo de datos que tenemos. 

 

ODV nos da la posibilidad de incluir también el “Missing Value indicator (s)” para 
que el programa sepa cuáles son los datos que no debe tener en cuenta ya que 
serían dados vacíos o erróneos. Para introducir este dato correctamente es 
conveniente revisar el archivo en formato de texto plano en el bloc de notas 
(archivo CSV) y no desde el Excel, porque a veces el Excel puede transformar 
la nomenclatura si no ha sabido entender bien el dato. 
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Diferenciar entre Metadatos y Datos, como indicaciones generales: 

‐ Metadatos: 
o Cruise 
o Station 
o Date 
o Year 
o Month 
o Day 
o Time 

‐ Datos: 
o Latitud (Latitude) 
o Longitud (Longitude) 
o Datos científicos: temperatura, salinidad, etc… 

 

Una vez pasamos la ventana anterior con éxito, ahora toca asociar las variables 
que se puedan. Como mínimo deben estar asociadas Latitud y Longitud (si no 
existen en el archivo original debemos crearlas con la opción “Set Default” como 
se vio anteriormente). 

Lo siguiente que nos pedirá es indicar qué tipo de datos son: 

 

‐ Data Field: si los datos proceden del océano o de la atmósfera. 
‐ Data Type: especificar si son perfiles, trayectorias o de qué tipo de datos 

se trata 
‐ Primary Variable: generalmente se considera la presión como variable 

principal, siempre y cuando estemos graficando estaciones tradicionales, 
con datos de superficie a una determinada profundidad. 

Si estos datos no se introducen en este punto, se podrán añadir posteriormente 
en “Collection”->”Properties”->”General” 
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Por último habrá que definir las variables a utilizar. Este punto no es crítico, ya 
que siempre se podrán definir más adelante. 

Una vez importados, sea arrastrando el archivo al icono o abriéndolo desde ODV, 
debe salir la siguiente ventana, donde se indica el número de estaciones que se 
han importado, y podremos chequear si es correcto respecto a los datos 
originales: 

 

 

Una vez introducimos los datos, las diferentes variables estarán identificadas con 
el nombre indicado en el cabecero del archivo. Salvo que haya sido escrito 
exactamente igual que las variables que identifica el ODV, será conveniente 
indicar al programa cuáles son las variables más importantes. Esto lo podemos 
hacer en “Collection” -> “Identify Key Variables”. 

 

 

2.1 IMPORTAR DATOS NET-CDF 
 

El ODV permite importar datos Net-Cdf, un tipo de formato jerárquico que son 
una tendencia creciente para guardar datos meteo-oceanográficos, ya que en el 
mismo archivo permite incluir los datos y metadatos de forma combinada e 
identificando claramente ambos.  

Para importarlos basta en hacer clic en  Import | Argo Formats | Float Profiles  
(como ejemplo práctico). 

Los Argo tienen dos tipos de archivos, los perfiles y las trayectorias, y se guardan 
en archivos separados. 
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Para ver el alcance geográfico de los datos hacemos clic con el botón derecho 
sobre el mapa, desplegando el menú contextual y haciendo clic finalmente en 
“Full Domain” consiguiendo un zoom en la zona donde hay datos.  

Seleccionando “Sample Selection Criteria” (Shift S) podemos ver el control de 
calidad del dato, especialmente importante cuando no conocemos la fuente de 
los datos y si están ya previamente filtrados o no. La diferencia de hacer un 
control de calidad de este tipo y seleccionar un rango de datos (“set range” en 
un gráfico), es que con esta última opción sólo estamos quitando un dato 
gráficamente, pero con el control de calidad del dato se puede definir un rango 
real de forma que elimine un dato ‘malo’ de toda la base de datos. 

 

 

3. GRAFICADO DE DATOS  
ODV muestra su potencial ofreciendo una serie de gráficos predefinidos 
que permiten presentar los datos de diferentes maneras permitiendo 
destacar las características que le interesen al usuario en un momento 
dado. 
 
Estos cinco tipos de gráficos son: 
- mapa de estaciones 
- gráficos de perfiles 
- diagramas de dispersión 
- secciones verticales 
- secciones horizontales 
 

3.1. MAPA DE ESTACIONES 
Con los datos introducidos podemos ver en el mapa dónde están situadas 
nuestras estaciones y qué datos tenemos. 

Para ello picamos “View” -> “Layout Templates” -> “Full Screen Map”; también 
se puede acceder con F8 de forma directa. 

 

En el mapa si se han cargado bien los datos se deben ver las estaciones como 
puntos azules. Con el ratón se puede seleccionar una estación que nos interese, 
y en la ventana derecha veremos toda la información detallada de dicha estación. 
Con las flechas derecha – izquierda podremos seleccionar otras estaciones de 
interés, y con las flechas arriba – abajo podremos cambiar la muestra dentro de 
cada estación (los diferentes datos dentro de un mismo perfil por ejemplo). 
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Se pueden hacer distintas proyecciones del mapa, situándonos encima del 
mapa, botón derecho “Properties” -> “Projection”. 

 

 

En la opción “View” se puede seleccionar los criterios por estaciones, de forma 
que aunque tengamos una base de datos completa, podemos representar sólo 
un subconjunto de datos en función de las estaciones de interés. 

 

3.2. PERFILES VERTICALES 
 

Una vez seleccionada la estación de interés en el mapa podemos graficar 
diferentes perfiles verticales. En el menú “View” -> “Layout Templates” -> “Station 
Windows”, hay la opción de graficar 1 perfil, 2 o 6 perfiles simultáneamente. El 
botón de acceso directo es F9. 
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Si sólo queremos mostrarla de forma puntual hacemos un click sobre la estación 
en el mapa a representar, mientras que si la queremos dejar fija hacemos doble 
clic o tecla intro. 

Dándole a intro fijas la estación en el perfil vertical y se puede superponer otra 
diferente; en caso de querer eliminar una estación de los perfiles verticales 
graficados, basta con seleccionarla y darle al botón borrar del teclado (←). 

 

Cada perfil puede ser editado individualmente; para hacerlo ponemos el cursor 
encima del gráfico a editar y le damos al botón derecho del ratón.  

 

 

Si lo que se desea es modificar el eje X o Y, lo más sencillo es situar el cursor 
encima del gráfico a editar y darle al botón X o Y según se desee. 

 

Cuando se selecciona la opción de datos procedentes del océano, el ODV toma 
automáticamente los datos de presión (o profundidad) con escala inversa, pero 
en caso de que no lo haga automáticamente se selecciona el recuadro inferior 
“Reverse range”. 
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Para hacer un zoom, se puede picar esa opción en el botón derecho, y se hace 
de forma gráfica (manual), y todos los perfiles cambian. 

Otra opción es picando en “set range”. De esta forma no se hace gráficamente 
sino con el dato, tanto en el eje x como en el eje y. 

 

Si se desea una combinación de perfiles verticales (o gráficos en general) 
diferente a la que viene por defecto (un perfil vertical, 2 ó 6), se puede 
personalizar la plantilla en la opción “View” -> “Layout Templates” -> “Windows 
Layout”. Esta plantilla se puede personalizar como se desee, modificando el 
tamaño y tipo de cada gráficos; para ello seleccionamos las opciones que se 
necesiten con el botón derecho del ratón una vez esté el cursor sobre el gráfico 
a modificar. 
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3.3. GRÁFICOS DE DISPERSIÓN 
 

En el menú “View” -> “Layout Templates” -> “Scatter Windows”, tenemos la 
opción de realizar 1 gráfico, 2 ó 6 simultáneamente. El botón de acceso directo 
es F10. 

Este tipo de gráficos plotea todas las estaciones simultáneamente, permitiendo 
tener una idea general de los datos que se tienen, calidad de los datos, puntos 
fuera de rango que se requiera filtrar, y una visión global de las masas de agua 
presentes en los datos bajo estudio. 

 

Este tipo de gráficos se puede filtrar por el tipo de estaciones que nos interese,  
o un determinado rango de cualquier propiedad. 

 

Uno de los diagramas de dispersión más característicos en oceanografía son los 
diagramas TS. Para que ODV nos identifique el diagrama como TS y nos permita 
añadir las isopicnas, debemos utilizar la temperatura potencial (Tθ), ya que con 
la temperatura in situ no se activará la opción de añadir isopicnas (lo que grafica 
es la anomalía de densidad, sigma). 
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Hay dos formas de añadir la temperatura potencial: 

 En una base de datos externa (u otro tipo de herramientas 
oceanográficas) y que esté incluida en las variables de entrada. En este 
caso es necesario identificar esta variable en el ODV como Tθ, porque en 
caso contrario seguirá sin activarse las isopicnas, porque ODV no sabe 
que se trata de temperatura potencial. 

 Calcular la temperatura potencial directamente en ODV como variable 
derivada (“View” -> “Derived Variables”). Si las variables de entrada no 
han sido introducidas previamente en el ODV e identificadas cada variable 
(en “Identify Key Variables”), el programa nos pedirá en este punto que 
las identifiquemos. Antes de hacer la temperatura potencial, deberemos 
calcular como variable derivada la profundidad a partir de la presión. 
Utilizar la ecuación del TEOS-10 para su cálculo. Si seguimos el TEOS-
10 deberemos utilizar la Temperatura Conservativa y la Salinidad 
Absoluta. Una vez añadida la temperatura potencial o la conservativa en 
el eje Y se activará la opción de Isopicnas en “Extras”. 

 

Una opción interesante sobre este tipo de gráficos, es utilizar datos de 
histogramas, picando sobre el gráfico “Extras”->“Windows Statistics”. En la 
opción “X/Y Distribution” veremos dónde se concentran el mayor número de 
datos dentro del TS (generalmente en aguas centrales y profundas). 

 

Con esto nos dará un gráfico estadístico de la repetición de un dato en un mismo 
punto; a veces puede parecer que hay menos datos en una zona porque salen 
superpuestos, pero con esta opción lo podremos saber. 
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Otra opción es que a un determinado gráfico de dispersión como un TS, se le 
puede añadir una variable Z (picando encima del gráfico la tecla Z), como puede 
ser el contenido en silicatos, nitratos u otra variable físico-química. 

 

 

3.4. SECCIONES VERTICALES 
 

Para generar secciones verticales, habrá que seleccionar “View” -> “Layout 
Templates” -> “Seccion Windows”, y seleccionar la sección sobre el mapa. El 
botón de acceso directo es F11. 
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“Manage Section” -> “Define Section” 

Se selecciona toda la sección a graficar. Si algún punto de los que se quieren 
graficar ha quedado fuera de la sección se puede ampliar la envolvente para 
incluirlo (“Mean Width”). 

 

En este punto hay que elegir si la sección se va definir en distancia, longitud (si 
es una sección horizontal) o latitud (si se trata de una sección vertical). Podemos 
añadir una batimetría si las estaciones son hasta fondo, o elegir la profunidad 
máxima de la estación como fondo. La batimetría que tiene por defecto el ODV 
tiene una resolución suficiente para la mayor parte de las zonas, pero en la web 
de ODV hay bases de datos de batimetría de 1 minuto de resolución espacial 
(lat-lon), que se pueden descargar. 

Por defecto el ODV tiene bases de datos de batimetría y líneas de costa muy 
básicas, que para datos regionales son insuficiente, como cuando hacemos 
zoom sobre el área de Canarias. Para cambiarlo se selecciona, “View”, 
“Settings”,  
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La batimetría se puede descargar desde la página de ODV y luego cargarlo en 
esta opción. También se puede cargar el contorno de la línea de costa, incluso 
de 30’’ * 30’’ a demanda, ya que si descargamos el fichero completo con 
cobertura global acaba ocupando demasiado espacio en nuestro disco duro. 

Una vez definida la sección vertical quedaría así: 

 

 

Definiendo la distancia en el Eje X y presión (o profundidad) en el Eje Y, se puede 
definir la variable Z que se desee, que en el gráfico anterior es Temperatura. Por 
defecto el ODV graficará los datos reales que se tengan en las estaciones 
muestreadas. Si se desea graficar mapas de contorno se hará un grid de los 
datos (“Properties” -> “Display Style”). En principio dejamos “Automatic Scale 
Length”, pero se puede editar si quedan huecos en blanco en el gráfico si la 
resolución de datos no es buena (editar sólo para el eje de poca resolución).  

 

En este último caso hay que 
tener cuidado con las 
interpolaciones que se hagan, 
ya que se corre el riesgo de que 
el suavizado sea tan acusado 
que se ‘borren’ estructuras 
reales existentes, así que es 
conveniente revisar bien y 
comparar entre las distintas 
escalas. 

Dejamos seleccionada la opción 
“Draw marks”, para que quede 
especificada en la sección sobre 
qué datos reales se está 
realizando el grid. 



Manual Docente de ODV para Oceanografía.                      D. Vega-Moreno y F. Machín. 2017 

 

pág. 17                                                                                                   ISBN: 978-84-16989-13-3 

 

En este caso ya se ha ampliado la escala en el eje Y, pero podría ampliarse aún 
más si se quisieran eliminar las dos manchas blancas que aparecen en la 
imagen; el “peligro” es suavizar tanto los datos que se pierdan las estructuras 
más superficiales. 

Una herramienta muy interesante de las secciones verticales es la superposición 
de diferentes secciones con valores de Z diferentes (el eje X e Y sí debe ser el 
mismo). 

Para hacerlo debemos terminar por completo la 1ª sección, ya que una vez 
superpongamos la segunda no nos permitirá editar la anterior, sólo la última. 

La opción para hacer esta superposición en ODV es “View”-> “Window Layout” -
> “Create Overlay Windows” 

 

 

Generalmente se usa como 1ª sección un diagrama de contornos suavizados y 
coloreados como el que se mostró, y como segunda sección los contornos de 
otra variable pero en formato de isolíneas. Para añadirlos se hace de forma 
equivalente al anterior, se pueden añadir todos iguales equidistantes, o remarcar 
uno en particular que nos interese a un determinado valor. 
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3.5. SECCIONES HORIZONTALES 
 
Para generar secciones horizontales, habrá que seleccionar “View” -> “Layout 
Templates” -> “Surface Windows”. Al igual que en resto de opciones permite 
diferentes gráficos superficiales simultáneamente. El botón de acceso directo es 
F12. Lo realizará sobre el mapa completo, o el zoom que hagamos de él, pero 
deberá aplicarse en campañas con datos que cubran un dominio tanto en latitud 
como en longitud, ya que no tiene demasiado sentido hacerlo si los datos siguen 
un único transecto recto; aunque también se puede hacer, el programa ploteará 
una serie de puntos coloreados en función del valor Z a representar a lo largo de 
una línea. 
Respecto a las formas de representar los datos, sigue el mismo criterio de las 
secciones verticales. Se pueden representar los datos reales en forma de puntos, 
o se pueden realizar mapas de contorno coloreados haciendo un grid de los 
datos. 

Este tipo de gráficas por defecto plotea los datos a nivel superficial, pero es 
posible graficar cualquier variable a cualquier profundidad (por ejemplo, salinidad 
a 1200 metros). Para hacerlo debemos crear una nueva variable de la siguiente 
forma: 
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Una vez creada esta nueva variable se introduce en el gráfico de superficie como 
variable Z. Estas opciones marcadas por ejemplo pueden ser útiles para detectar 
las principales aguas intermedias y su distribución geográfica, como podría ser 
el agua mediterránea. 

 

3.6. SERIES TEMPORALES 
 

Las series temporales son secciones verticales donde el eje X en vez de ser 
distancia, latitud o longitud es tiempo. 

Para hacer una serie temporal definimos una sección sobre todo el conjunto de 
datos (aunque no sea una sección realmente, sino todo el mapa). En otras 
palabras, hacemos una envolvente que lo cubra todo. 

Si la variable tiempo no está en la base de datos, habrá que definirla como 
variable derivada a partir de día, mes y año. En el menú de variables derivadas 
elegimos Time (station date & time), aunque es conveniente probar varias por si 
acaso alguna otra se ajuste mejor a los objetivos que perseguimos con el gráfico. 

En una serie temporal nos puede interesar hacer algo como esto: 

 

También podemos promediar los diferentes años como si fueran un único año 
para estudiar cambios climatológicos. 

 

En función de lo que se desee cambiaremos el dato del eje de las X. 
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4. CÁLCULOS EN ODV 
 

Aunque ODV tenga como objetivo fundamental proporcionar un entorno 
amigable para la visualización de datos, con el paso del tiempo ha ido 
incorporando herramientas para realizar cálculos sencillos o estandarizados. 

Por ejemplo, se pueden calcular velocidades geostróficas en ODV. Para ello 
existe una opción en “Tools”, que es “Geostrophic Flows”. 

Cuando hacemos este cálculo crea una nueva base de datos, como si fuese un 
nuevo conjunto de datos desde cero, ya que tendremos una estación menos que 
las originales en tanto que las velocidades geostróficas se obtienen comparando 
pares de estaciones. 

Uno de los elementos críticos en geostrofía es el nivel de referencia utilizado. 
Normalmente se emplea la aproximación del nivel de no movimiento, donde 
indicamos que la velocidad es cero y a partir de ahí conocemos el valor absoluto 
de la velocidad en toda la columna de agua. 

Para buscar el nivel de no movimiento en la zona de Canarias, una opción es 
buscar la masa de agua Agua Central del Atlántico Norte (NACW) y la masa de 
Agua Antártica Intermedia (AAIW), ya que la primera viaja hacia el sur y la 
segunda hacia el norte. De esta manera, en la interfase entre ambas la velocidad 
debe ser cero, con lo cual ahí podríamos ubicar nuestro nivel de no movimiento. 

Si el nivel de referencia lo ponemos en el fondo, estaremos dando más precisión 
a los datos de superficie, y menos interés en profundidad. Otra opción es darle 
un nivel de densidad de referencia, una densidad equivalente a zonas profundas. 
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Son muchas las variables derivadas que se pueden hacer en ODV, tanto físicas 
como químicas, pero habrá siempre que identificar las variables de entrada si 
previamente no han sido identificadas en el programa. 

 

5. EDICIÓN DE GRÁFICOS 
 

Para editar los títulos y textos, se selecciona el Eje y se pica en “Extras” -> 
“Manage Graphics Object”. 

Si queremos editar la sección que estamos haciendo (batimetría, distancia en 
vez de latitud o viceversa, etc), debemos ir al mapa y seleccionar “Manage 
Section” -> “Section Properties”. 

 

En el caso que se desee cambiar las etiquetas de las gráficas hay que ir a 
“Collection” -> “Properties” -> “Data Variables”. A la que quieras editar picas en 
ella y modificas el “label” (etiqueta), ya que por defecto aparecerá el nombre de 
la variable que tenga en la base de datos. Este cambio afectará a la variable en 
su conjunto, no sólo a un gráfico en particular, sino siempre que aparezca dicha 
variable. 

 

6. EDITOR DE MACROS 
 

El editor de Macros nos permite crear variables derivadas que no están incluidas 
en la lista por defecto de ODV. Es una pequeña herramienta de programación 
dentro del programa, como herramienta de cálculo. Utiliza lenguaje de 
programación con notación polaca inversa. 

Esta herramienta está dentro de “Tools” -> “Macro Editor” 

 

Las variables se nombran de la siguiente forma: #1 (seleccionar la variable 1 
dentro de la lista de nuestras variables), y así sucesivamente para las variables 
de entrada que estarán incluidas en la macro. 
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Este ejemplo equivaldría a NO= (9* (Nitratos)) + (Oxígeno) 

 

7. REFERENCIAS 
 

Toda la documentación relacionada con el programa Ocean Data View puede 
ser obtenida directamente desde la web oficial del programa, incluyendo el 
manual completo en inglés: 

Ocean Data View User’s Guide. Schlitzer, R., Ocean Data View, 
http://odv.awi.de, 2016. 

 

 

 


